[Rocks-Discuss] how to heal fsck? - fsck.ext3 for device /dev/sda1 exited with signal 7 - yum i386 vs. x86_64

BBrooks brian.brooks at acm.org
Wed Jun 6 11:54:49 PDT 2007


I'm having problems with a Rocks 4.1 install on an x86_64 machine.

[root at csgrid01 sbin]# uname -a
Linux 2.6.9-22.ELsmp #1 SMP Sat Oct 8 21:32:36 BST 2005 x86_64 x86_64
x86_64 GNU/Linux

My log files exhausted the root (/) file system.  I cleared off the
logs and attempted a reboot just to make sure all things were good.  I
think this reboot was the first in a very long time ~6 months.  The
reboot attempt kept failing, dumping the system to single user mode
with the error

  fsck.ext3 for device /dev/sda1 exited with signal 7

In single user mode, when I tried to run fsck.ext3 I would only get

  [root at csgrid01 sbin]# ./fsck.ext3
  Bus error

I booted the system using a recent ubuntu live cd and ran a fsck but
everything looked clean.  I then ran with the force option and a
little bit was found, see output below.  I ran ubuntu fsck a few more
times with force but no more problems were found.  Then another boot
attempt failed with the same 'exit with signal 7' message.  I then
discovered 'frontend rescue' and ran fsck but it didn't find anymore
issues either and still same error at boot.

Currently, I've worked around the issue by making /sbin/fsck.ext3 a
soft-link to /bin/true.

I thought the issue was the CPU architecture (see yum output below)
but the 'file' command says it is x86_64.  Although, yum does say my
system has both e2fsprogs.x86_64 and e2fsprogs.i386 (!) installed.  By
the way, in hopes of preventing this from happening in the future,
I've added 'exclude=*.i386 *.i586 *.i686' to /etc/yum.conf.  This was
suggested in a comment at http://bugs.centos.org/view.php?id=1356.

  [root at csgrid01 sbin]# file fsck.ext3
  fsck.ext3.dist: ELF 64-bit LSB executable, AMD x86-64, version 1
(SYSV), for GNU/Linux 2.4.0, statically linked, stripped

The only other symptom is ldd fails on the binary.

  [root at csgrid01 sbin]# ldd fsck.ext3
  ldd: exited with unknown exit code (135)

Any opinions on how to heal 'fsck'?

=== BEGIN UBUNTU FSCK OUTPUT ===
ubuntu at ubuntu:~$ sudo fsck /dev/sda1
fsck 1.39 (29-May-2006)
e2fsck 1.39 (29-May-2006)
/1: clean, 174011/768544 files, 1293937/1536207 blocks
ubuntu at ubuntu:~$ sudo fsck -f /dev/sda1
fsck 1.39 (29-May-2006)
e2fsck 1.39 (29-May-2006)
Pass 1: Checking inodes, blocks, and sizes
Inode 625915, i_blocks is 152, should be 144.  Fix<y>? yes

Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
Block bitmap differences:  -1520325
Fix<y>? yes

Free blocks count wrong for group #46 (6698, counted=6699).
Fix<y>? yes

Free blocks count wrong (242270, counted=242271).
Fix<y>? yes

/1: ***** FILE SYSTEM WAS MODIFIED *****
/1: 174011/768544 files (3.1% non-contiguous), 1293936/1536207 blocks
ubuntu at ubuntu:~$
=== END UBUNTU FSCK OUTPUT ===

=== BEGIN YUM OUTPUT ===
[root at csgrid01 etc]# yum whatprovides fsck.ext3
Repository update is listed more than once in the configuration
--snip--
Excluding Packages from CentOS-4 - Base
Finished
Importing Additional filelist information for packages


e2fsprogs.x86_64                         1.35-12.5.el4          base
Matched from:
/sbin/fsck.ext3
/usr/share/man/man8/fsck.ext3.8.gz


e2fsprogs.x86_64                         1.35-12.5.el4          base
Matched from:
/sbin/fsck.ext3
/usr/share/man/man8/fsck.ext3.8.gz


e2fsprogs.i386                           1.35-12.5.el4          installed
Matched from:
/sbin/fsck.ext3
/usr/share/man/man8/fsck.ext3.8.gz


e2fsprogs.i386                           1.35-12.4.EL4          installed
Matched from:
/sbin/fsck.ext3
/usr/share/man/man8/fsck.ext3.8.gz


e2fsprogs.x86_64                         1.35-12.5.el4          installed
Matched from:
/sbin/fsck.ext3
/usr/share/man/man8/fsck.ext3.8.gz
[root at csgrid01 etc]#
=== END YUM OUTPUT ===

In case it helps, here is my file system setup.  I took the default
partitioning scheme setup by Rocks

[root at csgrid01 sbin]# df -H
Filesystem             Size   Used  Avail Use% Mounted on
/dev/sda1              6.2G   5.1G   878M  86% /
none                   1.6G      0   1.6G   0% /dev/shm
/dev/sda3               65G    12G    50G  19% /state/partition1
tmpfs                  770M   3.0M   767M   1% /var/lib/ganglia/rrds
/state/partition1/home/postgres
                        65G    12G    50G  19% /home/postgres
/state/partition1/home/ksu-bbrook23
                        65G    12G    50G  19% /home/ksu-bbrook23
[root at csgrid01 sbin]# cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
LABEL=/1                /                       ext3    defaults        1 1
none                    /dev/pts                devpts  gid=5,mode=620  0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                    /proc                   proc    defaults        0 0
LABEL=/state/partitio1  /state/partition1       ext3    defaults        1 2
none                    /sys                    sysfs   defaults        0 0
LABEL=SWAP-sda2         swap                    swap    defaults        0 0

# The ram-backed filesystem for ganglia RRD graph databases.
tmpfs /var/lib/ganglia/rrds tmpfs
size=769472000,gid=nobody,uid=nobody,defaults 1 0
[root at csgrid01 sbin]#

--
Brian Brooks
(770) 794-9850
brian.brooks at acm.org / bbrook23 at students.kennesaw.edu


More information about the npaci-rocks-discussion mailing list