[Rocks-Discuss]DHCP problem with ROCKS 2.3.2

Suresh Singh suresh at cacr.caltech.edu
Wed Apr 23 11:53:25 PDT 2003


Thanks Greg, it did work with cross-over cable. So, switch was the problem.
Please let me know how to configure this Dell 5224 switch. The IP address of
the switch is in the same subnet of frontend and I can ping it.

Suresh


Greg Bruno wrote:

> > I am trying to build cluster with ROCKS 2.3.2. I am using Supermicro
> > P4DPE-G2 motherboard for frontend server and Supermicro X5DPE-G2 for
> > the
> > nodes. I successfully installed frontend server. However, I have
> > problem
> > in getting MAC address of client nodes through DHCP to frontend. The
> > insert-ethers commands waits for request indefinitely. The DHCP server
> > is
> > running on eth0 of frontend. All of these nodes have dual Intel 82546
> > EB
> > gigabit controllers. I am using CDROM in nodes for this. I am using
> > Dell
> > Powerconnect 5224 switch for the cluster. I did not have proplem with
> > Athlon based cluster in Asante switch. Any suggestion to relsove would
> > be
> > appreciated.
>
> the reason why insert-ethers is waiting forever is it is waiting for a
> DHCP discover message.
>
> here's a couple things to try:
>
> - try the other port on the compute node
>
> if that doesn't work, try:
>
> - bypass the switch by using a cross-over cable from the compute node
> to the frontend
>
> if the above works, then you know the switch is the problem. if it is
> the switch, we can help you to configure it (we a bunch in our lab).
>
> also, make sure the DHCP service is running:
>
>         # ps auwx | grep dhcp
>
> if it isn't, restart it:
>
>         # /etc/rc.d/init.d/dhcpd restart
>
>   - gb




More information about the npaci-rocks-discussion mailing list